• Mantenimiento Informatico para Infraestructura TI
  • +34 911 108 258
  • Enviar correo
  • Lun - Vie: 9:30 - 18:00

Como subir de versión jquery en WordPress

Jquery Error

Cuando se realiza alguna auditoria de página web o se intenta verificar si la página esta optimizada correctamente para los motores de búsqueda, algunas de estas herramientas pueden devolver un mensaje de tipo  

«Some third-party scripts may contain known security vulnerabilities that are easily identified and exploited by attackers
 
Library Version
Vulnerability Count
Highest Severity
2
Medium

«

donde nos avisa nuestra versión de jQuery y el numero de vulnerabilidades conocidas hasta esta fecha. 

Existen varias herramientas que determina quien utiliza nuestro jQuery y también varios plugins de WordPress que nos dice que siempre tendrás la ultima versión. 

Después que se instalan  estos plugins realizando otra vez la prueba de la página web nos vuelve a saltar el mismo mensaje. 

Ver la pestaña Solución.

Tiene que entrar en la parte de administración de WordPress. 

Apariencia WordPress

En el menú principal ir  al apartado Apariencia y seleccionar Editor de temas

Antes de editar el archivo php (functions.php) debe seleccionar el tema que esta utilizando su página web y pulsar el botón Elegir como en la siguiente imagen :

Selectionar tema en wordpress

Una vez seleccionado el tema buscar en Archivos del tema seleccionar el archivo llamado functions.php.

Abrir una nueva pestaña en su navegador de Internet para verificar la ultima versión de jquery disponible hasta la fecha o pulsar en : https://developers.google.com/speed/libraries/#jquery

En este caso la ultima versión es 3.4.1

last version jquery

En un bloc de notas o directamente en el editor de WordPress dentro del archivo functions.php insertar el siguiente código por encima de la ultima linea de código encontrado 

if( !is_admin()){
wp_deregister_script(‘jquery’);
wp_register_script(‘jquery’, («https://ajax.googleapis.com/ajax/libs/jquery/3.4.1/jquery.min.js»), false, »);
wp_enqueue_script(‘jquery’);
}

como en la siguiente imagen:

add lastversion jquery to wordpress

Este código «suprima» la versión de jquery que tienes instalada y utiliza la ultima versión disponible en Google en el sitio que has indicado en la ruta  -> «libs/jquery/3.4.1/»  

Después vuelve a verificar la página web si funciona correctamente. Puede comprobar su versión analizando su página con https://gtmetrix.com entrando en la pestaña waterfall y desplegando jquery.min.js como la la siguiente imagen:

jquery google api

Contacta con nosotros para enviarte el enlace con la descarga del programa o si necesita nuestra ayuda de forma gratuita. 

Share on facebook
Facebook
Share on google
Google+
Share on twitter
Twitter
Share on linkedin
LinkedIn
Share on pinterest
Pinterest
Mantenimiento Informatico

Mantenimiento Informatico

Gracias por visitar nuestra página. Comparte esta página para poder ayudar a los demás.

Deje su comentario

× Iniciar chat.